Still experiencing some delays in invalidating resources
Incident Report for Cloudinary
Resolved
The CDN invalidation issue is now resolved.
Posted Sep 12, 2018 - 14:28 EDT
Identified
Our CDN provider has identified the issue and working on a fix.
Posted Sep 12, 2018 - 11:35 EDT