High latency when using the Cloudinary console

Incident Report for Cloudinary

Resolved

The issue has been resolved, and system performance has returned to normal.
Posted Feb 11, 2026 - 02:04 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 10, 2026 - 12:55 EST

Investigating

From 2:30 PM UTC, we are seeing degraded performance when accessing the Cloudinary console. We are currently investigating the issue.
Posted Feb 10, 2026 - 10:44 EST
This incident affected: Digital Asset Management (DAM) and Management Console.