Paypal payments problems
Incident Report for Cloudinary
Resolved
The issue has been resolved and Paypal payments work properly now.
Posted Feb 15, 2018 - 07:30 EST
Identified
We are experiencing problems with Paypal payments, we are in touch with Paypal to resolve the issue. Meanwhile, if you are using Paypal as your payment method and need to change your Cloudinary plan you can either switch to credit card payments or postpone the update until the issue will be resolved.
Posted Feb 15, 2018 - 03:49 EST