Failed payments due to an issue with one of our payment providers
Incident Report for Cloudinary
Resolved
The payment issue has been resolved.
Posted Apr 07, 2020 - 04:10 EDT
Monitoring
Issue has been resolved by our payment provider at 17:50 UTC. Failed payments will be retried in the next few hours. We will keep monitoring on the issue
Posted Apr 06, 2020 - 14:06 EDT
Identified
Due to a global issue with one of our payment providers, some customers may have received a "Payment failed" notifications email. The issue started at around 10:30 (UTC) and is expected to be resolved later today. Updates to follow.
Posted Apr 06, 2020 - 09:06 EDT