Elevated Error rates when fetching assets from twitter
Incident Report for Cloudinary
Resolved
Following recent changes to Twitter's API policies and access tiers, it's no longer possible for us to fetch new profile pictures from Twitter on our customers' behalf without using customer-specific credentials, or to refresh previously-fetched pictures.
Existing Twitter profile pictures cached in your account's storage will continue to be accessible.

Customers who wish to continue using this feature to fetch new profile pictures can provide Cloudinary with API access credentials that should be used when calling Twitter's API on their behalf.

To provide us with your API access credentials, please contact our support team by submitting a request at https://support.cloudinary.com

For more details about signing up for Twitter's API and generating the necessary tokens, please see their documentation.
Posted Jul 21, 2023 - 05:58 EDT
Identified
Twitter has changed its API and Terms and Conditions which has caused non-cached entries to fail. We're evaluating how to proceed.
Posted Jul 19, 2023 - 10:30 EDT
Investigating
From 8:12 PM UTC on July 18th, we noticed a higher level of errors in requests when fetching resources from Twitter. We are currently investigating the issue to provide a fix. Further updates to follow.
Posted Jul 19, 2023 - 05:04 EDT
This incident affected: Media Delivery.