Failed transformation requests with combination of Strict Transformations and Auto-Upload

Incident Report for Cloudinary

Resolved

This incident has been resolved.
Posted Dec 15, 2025 - 14:32 EST

Monitoring

A fix has been deployed and affected requests should now be working as expected. We'll resolve the incident after some further monitoring.
Posted Dec 15, 2025 - 12:42 EST

Update

We are working on deploying a fix for this issue; we'll provide a further update after the deployment is complete
Posted Dec 15, 2025 - 11:51 EST

Identified

We are currently working to resolve a reported issue when using both Strict Transformations and the Auto-Upload feature. Until we resolve the issue, you may see "Transformation ... is not allowed" errors on requests that should trigger an auto upload from a remote URL or bucket. Until we resolve the issue, you can work around the issue by temporarily disabling Strict Transformations or using another method to allow the transformation to proceed such as signing the URL or adding an Strict Referral Domain: https://cloudinary.com/documentation/control_access_to_media#strict_transformations
Posted Dec 15, 2025 - 10:10 EST
This incident affected: US Datacenter (Media Transformation API - US, Upload API - US), AP Datacenter (Media Transformation API - AP, Upload API - AP), and EU Datacenter (Upload API - EU, Admin API - EU).