After several hours of further monitoring, we've confirmed that webhooks notification queues have remained stable and new notifications are being processed as expected.
Posted Jul 04, 2025 - 04:52 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2025 - 12:52 EDT
Investigating
We are aware that webhook notifications aren't being received and are investigating it.
Posted Jul 03, 2025 - 10:51 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2025 - 07:55 EDT
Update
We are continuing to investigate this issue.
Posted Jul 03, 2025 - 06:37 EDT
Investigating
We are currently experiencing delays in our webhook notification delivery system. Customers may observe that webhook events are delivered later than expected.
Our engineering team is actively investigating the root cause and working to restore normal delivery speeds. We will provide updates as more information becomes available.
Posted Jul 03, 2025 - 06:13 EDT
This incident affected: US Datacenter (Webhooks / HTTP notifications - US).