Degraded performances when using the Media Library

Incident Report for Cloudinary

Resolved

This incident has been resolved.
Posted Jan 08, 2026 - 12:05 EST

Monitoring

Our team identified the cause of the issue and reverted to a known working version. We expect the Media Library's functionality to be fully restored, and we are continually monitoring the status.
Posted Jan 08, 2026 - 10:56 EST

Investigating

Starting 2:45 PM UTC, we are seeing degraded performance when accessing the Media Library via the console and the widget. We are currently investigating the issue.
Posted Jan 08, 2026 - 10:47 EST
This incident affected: Digital Asset Management (DAM) and Media Library Widget.