Billing Dashboard and Plans Outage

Incident Report for Cloudinary

Resolved

This incident has been resolved.
Posted Dec 21, 2025 - 09:43 EST

Monitoring

At approximately 9:20 AM until 10:20 AM UTC, some users may have experienced outages in the following areas:
- Billing dashboard (whole billing submenu)
- Plan Upgrade / Downgrade
- Signing up for a paid plan

Issues were acknowledged quickly, and the system has returned to normal.
Cloudinary support is continuing to monitor. Please open a support ticket if you experience any issues or have any questions.
Posted Dec 21, 2025 - 05:50 EST
This incident affected: Billing.