Media library indexing issue
Incident Report for Cloudinary
Resolved
The backlog has been consumed and system is operating normally. Please contact support@cloudinary.com with any questions.
Posted Mar 07, 2019 - 19:13 EST
Update
The fix has been successful and the backlog of updating the media library with changes is recovering at the maximum rate possible. With the current rate, we expect the backlog of updates to complete recovery within 2 hours. Until then, for approximately half of folder and file update operations, the media library will only reflect them when the backlog is consumed. We realize the adverse effect this has on our users and will perform system changes that will prevent this type of incident from repeating. We will update this incident once the backlog is recovered.
Posted Mar 07, 2019 - 17:49 EST
Monitoring
We have deployed a fix and are monitoring the system as the indexing recovers its backlog of library updates
Posted Mar 07, 2019 - 16:36 EST
Identified
The issue began 16:46 UTC, we have identified the media library indexing component that has failed and are working on a fix.
Posted Mar 07, 2019 - 15:59 EST
Investigating
We are currently experiencing an issue in the media library which may prevent access to newly generated folders and files, and cause deleted folders and files to remain in the media library as if they weren't deleted. Our team is actively working on it and we will update with more details.
Posted Mar 07, 2019 - 15:23 EST
This incident affected: Management Console.