Degraded Performance - Usage Data & Reporting Delays

Incident Report for Cloudinary

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 16:40 EDT

Investigating

Following an incident with a third-party service provider, we’re experiencing delays in receiving and processing usage data. Until this is resolved, dashboards and reports in your account may load inconsistently or appear out of date (missing the last few hours of usage).
Posted Oct 20, 2025 - 09:29 EDT
This incident affects: Digital Asset Management (DAM) and Billing.